VMWare: Unable to contact a primary HA Agent


So, after a major hiccup that left 6 out of my 7 member-vmware-esx-cluster disconnected from the main datastore, thus causing them to be kicked out of the cluster, I found out that after I managed to salvage the nodes, I can’t re-enable HA. The “Reconfigure for VM HA” command -which strangely is placed right under “remove”- return this error:

“Unable to contact a primary HA agent”

The “vmkping” showed that vm-kernel network are working between the nodes, and everything else seems to be fine. I even restarted the VCenter server just  to make sure.

What you need to do is to disable VM HA from cluster level, and re-enable them again. To do that, right click on the cluster, and select “edit settings”. Uncheck the “Turn On VMWare HA”, and press OK.

VM HA option
VM HA option

Observe the progress bar of each nodes, and wait for all of them to finish the process. After that, right click on the cluster, select “edit settings” again, and re-check the “Turn On VMWare HA” box, then press “OK”. After all nodes finished the reconfiguration process, you should have your HA back.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s