Registering new IBM tape drive on Redhat Linux


So, we recently swapped 3 faulty tape drives on our TS3310. The library is connected through FC, so there’s no need for the box to be booted off for us to remove the broken drives, and install the new one. Please be informed that the guide is only applicable for IBM tape drive using lin_tape, on RHEL box. Since RHEL won’t automatically register the new drives, you need to either reboot the box, or:

Stop the lin_taped daemon
What we basically must do is to unload and reload the lin_tape module. To unload, we need to stop any service that use lin_tape. To stop the lin_taped daemon, do the following:

/usr/bin/lin_taped stop

Unload and reload the lin_tape module from the kernel

To unload the lin_tape module from the kernel, do the following:

modprobe -r lin_tape

..and to reload:

modprobe lin_tape

Check the serial numbers and the drives’ status and

To make sure that new drives are registered, compare the new drives serial number to your documentation:

[root@hqdwhbe1 ~]# cat /proc/scsi/IBMtape 
lin_tape version: 1.10.0
lin_tape major number: 250
Attached Tape Devices:
Number  model       SN                HBA                             FO Path   
0       ULT3580-TD4 1310283865        qla2xxx                         NA        
1       ULT3580-TD4 1310279631        qla2xxx                         NA        
2       ULT3580-TD4 1310135028        qla2xxx                         NA        
3       ULT3580-TD4 1310136063        qla2xxx                         NA        
4       ULT3580-TD4 1310232424        qla2xxx                         NA        
5       ULT3580-TD4 1310227740        qla2xxx                         NA

Notice the “attached number” and the new serial numbers, in my case, those are 1310283865 and 1310279631, so it will be registered as /dev/IBMtape0 and /dev/IBMtape1 respectively.  To see if the drives are accessible on OS level, do the following:

mt -f /dev/IBMtape0 status

If RHEL can access the drives, the output should be similar to this:

[root@hqdwhbe1 ~]# mt -f /dev/IBMtape0 status
SCSI 2 tape drive:
File number=-1, block number=-1, partition=0.
Tape block size 0 bytes. Density code 0x46 (no translation).
Soft error count since last status=0
General status bits on (40000):
DR_OPEN

Start the lin_tape daemon

To start the lin_tape  daemon, do the following:

/usr/bin/lin_taped start

…And we’re done. The next we should do is to test whether your backup system (TSM, BackupExec) is working with the new drive

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s