Email problem on Blackberry, Exchange 2003, and Cisco ASA,


My mail server has been experiencing strange problem. Emails sent from gmail and yahoo via blackberries failed to reach its intended recipients. Gmail and Yahoo mailer daemons would complain about connection timeout, and and then give up. My Trend Micro IMS antispam server log showed that google server initiated a session, but nothing happened after that. Whitelisting and increasing session timeout didn’t help.

I did notice unusual behaviour when telneting other SMTP servers from my mail server:

surfer@Mach5-M:~$ telnet smtp.cbn.net.id 25
Trying 210.210.145.16...
Connected to smtp.cbn.net.id.
Escape character is '^]'.
220 *********************
ehlo there
500 #5.5.1 command not recognized

This is due to our mail server sitting behind a Cisco ASA, and our network guy activating “inspect” on smtp traffics. After disabling “inspect” on the ASA with

# no inspect esmtp

email sent from gmail and yahoo via blackberries run normally and can be delivered to its target.

Replacing Emoji...
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s